BB-CLS X-CSL und sichtbare Planes

Hallo,
Wenn ich in xPilot 1.1.1.0 ein wenig observe stelle ich Folgendes fest:

Ein Pilot ist mit einer B789 unterwegs, ich sehe kein model, nur das callsign.
Noch einer ist mit einer F35 unterwegs, das Gleiche.
Die callsigns schleichen die taxiways entlang und machen ihr takeoff.

Ich habe die BB-CSLs und die X-CSLs installiert. Eine B789 und/oder F35 sind da nicht drin...
Im Prinzip kann/muss ich damit leben
Im ww-net kann ich keine weiteren CSLs finden. Gibt's irgendwo noch welche?

Ansonsten läuft xPilot 1.1.1.0 schon ziemlich rund bei mir.
 
Wo genau (in welchem Ordner) liegen Deine CSL-Dateien? Offensichtlich kann xPilot nicht darauf zugreifen, um sie im SIM zu zeigen. Ich nutze zwar swift, aber dort gäbe es exakt dasselbe Problem, wenn swift bzw. X-Plane diese nicht darstellen könnte. Und hast Du wirklich alle anderen Plugins entfernt/verschoben, die da reinfunken könnten?
 
Bei mir sieht das so aus und es funkt, ich habe nicht den Eindruck dass es an den Pfaden liegt, siehe auch CLS posts in diesem Unterforum:

mit Haken resources/plugins/xpilot/resources/csl (da is nix drin, das ist leer, weil ich auch mit swift experimentiere...)
mit Haken D:\XP11\CSL (da sind die BB-CLS und die X-CLS also ALLES drin.)

Ich glaube dass der slash / nicht richtig funkt und man den backslash \ braucht, könnte sein....

Wenn ich xPilot nutze ist nichts mehr auf der Platte! schon garnicht in irgendwelchen Verzeichnissen von swift und umgekehrt.

@Andreas: Siehst Du mit swift B789er und F35-Fighter? Ansonsten sehe ich alle planes glasklar, wenn ca. 20 am AP stehen, und die benehmen sich auch ansändig. Bin jetzt bei xPilot 1.1.1.1 Beta angekommen.
 
Zuletzt bearbeitet:
Hast Du die Pfad-Bezeichnung manuell eingegeben oder per "Browser" ausgewählt? Falls über den Explorer ausgewählt wurde sollte das Format stimmen.
 
Man kann bei xPilot die Pfadangabe nur im Plugin bei X-Plane machen und dies auch nur "händisch" - es gehen weder Copy&Paste noch irgendwelcher Browser-Aufrufe. Bei mir finktioniert es aber auch mid "/" statt "\" - worüber ich als alter Unix-User sehr froh bin ;) *
Bitte denkt aber immer daran, dass der xPilot nur zwei Ordner "in die Tiefe" schaut. Habt ihr also Eure BB-CSL-Ordner zum Beispiel unter "../X-Plane/Resources/plugins/xPilot/Resources/CSL/BB-CSL/BB_GA/..." und gebt im den xPilot Clienten als Verzeichnis nur "../Resources/CSL" an, so werden die xsb-aircraft.txt NICHT gefunden, da sie von dieser Position aus im 3. Unterordner liegen. Hier musst dann also explizit auch "../Resources/CSL/BB-CSL" mit angegeben werden!

* Update(12.11.2019):
Die Konfiguraionsdatei für das xPilot-Plugin befindet sich unter .../X-Plane/Output/preferences/Xpilot.prf
Die Einstellungen können daher auch VOR dem Start von X-Plane mit einem Texteditor in dieser Konfigurationsdatei gemacht werden.
 
Zuletzt bearbeitet:
Dann mach mich doch bitte mal klug, damit wäre zumindest mir mehr geholfen als mit dieser Antwort.
Ich finde nur im plugin die Möglichkeit der Pfadangabe und habe auch noch nicht gefunden, wo diese gespeichert wird. Zusätzlich setzt mir der Plugin auch immer wieder die Zeile "Resources/plugins/xPilot/Resources/CSL" oben in diese Liste hinein. Bei der Installation kann ich mich nicht daran erinnern, nach einem CSL-Directory gefragt worden zu sein.
Oder bezog sich Deine Aussage "Schrott" lediglich auf den xPilot und nicht auf meinen Beitrag - dann vergiss, was ich gerade geschrieben habe ;)
 
Ich habe den default-Pfad:

resources/plugins/xpilot/resources/csl (da ist wie oben schon gesagt nix drin)

einfach als dummy dringelassen und aktiviert. Nach meiner Erfahrung kann ich die CSLs dann hinlegen wo ich will, z.B. eben auch in die root von X-Plane11 (s.o.) Bei mir geht das.
Und das mit den 2 Verzeichnistiefen ist dann auch in jedem Fall gewährleistet.;)
 
Dann mach mich doch bitte mal klug, damit wäre zumindest mir mehr geholfen als mit dieser Antwort.
Neeeeeeeeee, mit "Schrott" meinte ich eigentlich (ich dachte das wäre klar), dass man als Nutzer von xPilot nicht per Datei-Browsing den CSL-Pfad auswählen und speichern kann. Dafür eine manuelle Eingabe zu fordern erzeugt eine hohe Fehleranfälligkeit, wie wir bereits gesehen haben.
 
Ich habe den default-Pfad:
resources/plugins/xpilot/resources/csl (da ist wie oben schon gesagt nix drin)
Laut Anleitung soll der Pfad (angeblich) case-sensitiv sein - also unbedingt auf richtige Groß-/Kleinschreibung achten!
Wie Andreas schon richtig sagte - durch die "händische" Eingabe passieren massive Fehler, zumal die Plugnis an dieser Stelle auch kein Copy&Paste zulassen und sogar ein Leerzeichen nur durch Strg-Leerzeichen eingegeben werden kann.
 
Gehe ich also richtig in der Annahme das die X-CSLs (die ja aktueller sind und ständig aktualisiert werden) nicht mit xPilot funktionieren? Also bei mir gehen nur die "alten" BBs
 
Die X-CSLs sollten eigentlich auch funktionieren, den sie basieren auf demselben Prinzip. Sie müssen nur richtig verlinkt werden, damit xPilot sie auch findet.

Kann das bitte jemand bestätigen oder dementieren?
 
Also ich hab alles versucht...hab die CSL's im X-IvAP Ordner verlinkt...ging nicht! Hab sie in den Xpilot/CSL verschoben und verlinkt, ging auch nicht! Aber was weis ich schon...vielleicht hat jemand eine Lösung, denn ich würde auch gern die X-CSL's nutzen. Hab's jetzt so gemacht, wie ein bekannter YouTuber und hab beide Verzeichnisse verlinkt...geht jetzt auch aber halt nur die BB's
 
Eigentlich habe ich oben schon alles gesagt und beschrieben.

Das default CLS Verzeichnis von xPilot habe ich einfach gelassen und aktiviert, mit nichts drin, also leer, als dummy quasi.
Nach D:\XP11\CSL habe ich die BBs und nebendran ins gleiche Verzeichnis die X-CSLs gelegt, beide werden erkannt.

mit gesetztem Haken "Resources/plugins/xpilot/Resources/CSL" (da is nix drin, das ist leer),
wie Michael Wellner geschrieben hat muß das case-korrekt angegeben werden, das ist hier bei mir in der Schnelle dieses posts vielleicht bei mir nicht ganz korrekt, also den default Pfad von xPilot einfach so lassen wie er ist und Finger weg..

mit Haken gesetzt "D:\XP11\CSL" (da sind die BB-CLS und daneben die X-CLS also ALLES drin). Funkt tadellos.

Wer Flugsimulatoren installiert und eine Pilotenausbildung macht, sollte auch ein paar Verzeichnisstrukturen auf seinem Rechner im Griff haben (sorry!).

Das Ganze kann ich auch umkehren, die "D:\XP11\CSL" leer lassen und die "Resources/plugins/xpilot/Resources/CSL" füllen mit beiden CSLs, funkt auch.

xPilot wird immer besser und ist ein wunderbar kleiner und handlicher client der leicht zu bedienen ist und (für mich) alles bietet. Als Beta schon sehr brauchbar und ich bin zuversichtlich das er aus den Kinderkrankheiten kommt, die allerdings (für mich) kaum noch zu merken sind.

Exotische Flugzeuge, wie F35-Fighter oder B789er sieht man ja nicht allzu oft, die werden bis jetzt nur mir callsign gezeigt weil keine models dafür vorhanden sind. Für mich kein Problem.
Eine kleine Make will ich nicht verschweigen, VFR-Flugzeuge scheinen noch halb im ground zu liegen, während airliner seltsamerweise alle voll und mit
Rädern dargestellt werden.

Jetzt hab ich mein Pulver verschossen... Weidmanns Heil.
 
Oben