CTD Problem - Swift und X-Plane 11

Hallo zusammen,

ich bin Swift-Nutzer erster Stunde und nach wie vor begeistet von diesem Client.
Seit ca. 2 Monaten habe bei fast jedem Flug irgendwann einen CTD, meist nach Erreichen des Cruiselevels, selten gleich zu Beginn. Eine eindeutige Fehlermeldung hat meine Analyse von über 30 xp-logs nicht ergeben. Gibt es innerhalb Swift eine Möglichkeit, Fehler in einem Log zu finden?

Ich nutze X-Plane seit Version 8 und glaube, das XP Universum und deren Technik ganz gut zu verstehen.

Anfangs war ich gar nicht auf die Idee gekommen, es könnte mit Swift zusammenhängen. Erst ein Wechsel zu X-Pilot brachte die Erkenntnis - da damit kein einziger CTD mehr passierte. Der Client gefällt mir aber aus mehreren Gründen nicht.

Gestern habe ich dann die Beta 0.12.2 samt passendem plugin neu geladen und installiert, Testflug begonnen, nach ca. 40 Minuten wieder CTD ohne Logeintrag. Ich nutze die aktuellste XP11 (gestern ebenfalls aktualisiert), den aktuellen NVIDIA Treiber. Gestriger Flug war mit dem Toliss A321. Ich habe das ganze aber auch mit allen anderen Addons, iniSim, Rotate, FF, Justflight, Zibo,...

Da das Problem jahrelang nie auftrat bin ich gerad am Ende meines Lateins. Ich habe inzwischen auch die wenigen genutzten Plugins wie Avitab oder Better Pushback aktualisiert. Sind sonst vielleicht Wechselwirkungen mit anderen Plugins und Xswiftbus bekannt?

Nach über 15 Jahren vergeht mir zum ersten Mal die Lust am Simulator, weil man gar nicht mehr losfliegen mag. Ein Gefühl, das ich aus meiner X-Plane Zeit gar nicht kenne. Da ich wenig Plugins habe lief der SIM immer stabil.

Ich bin für jeden Hinweis dankbar.

Gruss, Martin
 
Zuletzt bearbeitet:
Hallo Martin,
es ist zwar nie auszuschließen, dass es wirklich an swift liegt. Meist liegt die Ursache aber woanders. Bitte sammel so viele Daten wie möglich und stell sie uns zur Verfügung. log.txt aus dem Root-Folder von X-Plane, Crash-Reports (.dmp) aus /Output/crash_reports oder Auszüge aus der Windows-Ereignisanzeige.

Ohne solche Daten ist es Stochern im Nebel.
 
Hallo Daniel,
danke für Deine Antwort. Es trat halt die ganze ohne Swift nicht auf - beim ersten Flug mit Swift war der Crash zurück.

Ich werde heute oder die nächsten den identischen Flug machen und die gesammelten Daten hier posten. Ich würde mich sehr über jede Hilfe freuen :)
Gruss, Martin
 
Hallo,
hier die Dateien. Ein Crash-Report ist nicht erzeugt worden. Was im Eventlog auffällt: Zum Crashzeitpunkt gibt es einen nVidia Open-GL Fehler. XP läuft aber mit Vulcan.
Und wie gesagt, es passiert nur bei Einsatz von Swift. Danke für jede Hilfe! Gruss, Martin

Download bei Dropbox
 
Hallo Martin,

dein Log zeigt für mich nichts auffälliges. Was sagt deine Windows Ereignisanzeige?
 
Ju, sorry. War alles da. Sieht eindeutig nach Graka aus. Sorry, aber nichts was irgendwie auf swift hindeutet.
 
Unter Xpilot war das Problem wochenlang weg - mit der Installation von Swift trat es bei jedem einzelnen Flug bisher auf.
Hast Du eine Idee, wieso es ein OpenGL Fehler ist, wo XP doch mit Vulcan läuft
 
Ich stecke da jetzt nicht all zu tief drin, aber interessant ist erstmal nur, dass der Treiber abstürzt.
Code:
Name des fehlerhaften Moduls: nvoglv64.dll, Version: 30.0.15.1179, Zeitstempel: 0x62046bd5

Warum in der anderen Fehlermeldung als Quelle
Code:
NVIDIA OpenGL Driver
steht, kann ich nicht sagen. X-Plane lief bei dir auf jeden Fall mit Vulkan.

Gute Ratschläge habe ich erstmal nicht außer die üblichen Parameter der Grafikkarte überwachen und deine Plugins mal alle rausnehmen. Dass du einen Crash "nur" mit swift hast, muss glaube ich erstmal so stehen gelassen werden. Vermutlich eher ein Zufall.
 
Nun habe ich gerade den exakt gleichen Flug gemacht wie beim geschickten Crash. Ergebnis: Gefühlt an genau der selben Stelle über der Schweiz wieder ein CTD.
Wieder mit OpenGL Fehler im Eventlog. Das ist doch echt zum !"§$%&/()=
 
Welche Treiberversion nutzt Du denn? Hast Du den Treiber schonmal komplett neu installiert?

Was ich bei NVidia grundsätzlich empfehle, ist eine Installation mit NVCleanInstall. Der große Vorteil des Tools ist, dass Du die einzelnen Treibermodule auswählen kannst, die Du installieren möchtest. Damit kannst Du den Treiber schlank halten und Teile, die Du nicht brauchst (z.B. GeForce Experience, 3D-Stereobrille, Notebookoptimierungen) weglassen.
 
Welche Treiberversion nutzt Du denn? Hast Du den Treiber schonmal komplett neu installiert?

Was ich bei NVidia grundsätzlich empfehle, ist eine Installation mit NVCleanInstall. Der große Vorteil des Tools ist, dass Du die einzelnen Treibermodule auswählen kannst, die Du installieren möchtest. Damit kannst Du den Treiber schlank halten und Teile, die Du nicht brauchst (z.B. GeForce Experience, 3D-Stereobrille, Notebookoptimierungen) weglassen.
Hallo Stephan,
Ich nutze den aktuellsten. Danke für den Tipp! Mich nervt tatsächlich der ganze Überbau mit der GFExperience. Ich werde den Treiber mal neu installieren.
 
Dass der Grafiktreiber als Absturzursache von Windows genannt wird muss nicht zwingend auf ein Problem mit der Grafik hindeuten, scheinbar meldet Windows das (zumindest mit Vulkan) auch wenn ein die Grafik nutzendes Programm aus anderen Gründen abstürzt oder von Windows beendet wird.

Dass trotz Vulkan OpenGL genannt wird hat mich auch gewundert, scheint aber bei X-Plane normal zu sein. Könnte evtl. auch daran liegen, dass X-Plane wenn ich es richtig verstanden habe Plugins weiter mit OpenGL zeichnen lässt und dann das entstehende Bild nach Vulkan überträgt.

Schau mal ob es unter "System" in der Ereignisanzeige zu den Absturz-Zeitpunkten eventuell einen Hinweis auf eine Out-of-Memory-Situation gibt, das war bei mir ein immer an gleicher Stelle reproduzierbar auftretender Fall. Die deutsche Übersetzung der Meldung wurde grad in einem anderen Thread gepostet: https://board.vatsim-germany.org/threads/ctd-nach-Überlaufen-des-virtuellen-speichers-durch-searchapp-exe.67933/
 
Schau mal ob es unter "System" in der Ereignisanzeige zu den Absturz-Zeitpunkten eventuell einen Hinweis auf eine Out-of-Memory-Situation gibt, das war bei mir ein immer an gleicher Stelle reproduzierbar auftretender Fall. Die deutsche Übersetzung der Meldung wurde grad in einem anderen Thread gepostet: https://board.vatsim-germany.org/threads/ctd-nach-Überlaufen-des-virtuellen-speichers-durch-searchapp-exe.67933/
Hallo Daniel,
nein - den Fehler habe ich nicht. Aber wenige Sekunden vor der Meldung NVIDIA OpenGL Driver gibt es im Systemprotokoll diese Meldungen:
https://www.dropbox.com/s/lqpxdaqobzq4p1x/21h11_system.evtx?dl=0
 
Hm, da steht ja, dass die Shader Probleme machen. Verwendest Du irgendwelche Tools, die daran rumdoktorn? Wenn ja, deaktiviere die mal testweise.

Generell lösch mal die Verzeichnisse unter Output/shadercache, dann kompiliert X-Plane die Shader beim nächsten Start neu. Es kann passieren (sollte eigentlich nicht), dass X-Plane den Wechsel einer Grafiktreiberversion nicht mitbekommt und für eine falsche Version kompilierte Shader weiterbenutzt. Und es ist mir leider auch schon passiert, dass Windows 10 meinte einfach mal so während des Betriebs (ich meine da lief sogar grad X-Plane) die Treiber auszuwechseln, weil es unbedingt im Hintergrund Updates installieren musste. Auch passiert es dabei leider immer wieder, dass Windows 10 neuere Treiber (selbst installiert) durch ältere (via Windows Update verteilt) ersetzt.
 
Hallo zusammen,
Ich habe nun mit einem Tool den Nvidia Treiber deinstalliert, dann den Treiber frisch installiert und den Shadercache gelöscht. Bisher zwei Flüge ohne Absturz. Ich hoffe, es bleibt so. Ich möchte Euch allen für die Tipps danken. Sollte es doch wieder auftreten, melde ich mich hier wieder. Gruss, Martin
 
Hallo zusammen,
Ich habe nun mit einem Tool den Nvidia Treiber deinstalliert, dann den Treiber frisch installiert und den Shadercache gelöscht. Bisher zwei Flüge ohne Absturz. Ich hoffe, es bleibt so. Ich möchte Euch allen für die Tipps danken. Sollte es doch wieder auftreten, melde ich mich hier wieder. Gruss, Martin
Auch 3 Wochen später noch kein einziger CTD - der Fehler scheint tatsächlich behoben!
 
Oben