Euroscope Connection nicht möglich

Moin,
Ich habe nun nach mehreren Re-Installs mehrmals das selbe Problem gehabt. Sobald ich Euroscope starte erscheinen bereits mehrere Error Meldungen.

Wie man bereits oben erkennen kann bekomme ich dann sobald ich versuche mich als OBS zu verbinden den ERROR 10061.
Ich kann als jemand der noch kaum mit Vatsim und Euroscope gearbeitet hat den Fehler momentan nicht wirklich einordnen. Falls jemand Lösungsvorschläge hat wäre das sehr hilfreich.

MfG,
Hendrik
 

Adam Trzcinski

1125672
RG Düsseldorf - Mentor
Failed to create file
Das spricht für ein Problem mit Berechtigungen von EuroScope in den Ordner zu Schreiben. Bist du Admin auf deinem Rechner? Ist UAC ein oder ausgeschaltet?
 
Eigentlich sollte Euroscope die Berechtigungen dazu haben. ICh hab es aber jetzt geschafft, dass Euroscope wieder funktioniert. Die Errors kommen zwar größtenteils weiterhin scheinen die Funktion nicht zu beeinträchtigen
 

Dominik Samuelis

842558
RG Frankfurt - NAV
Stimme @Adam Trzcinski zu, das ist ein Berechtigungsproblem. Euroscope legt bei jedem Start einen Haufen Dateien neu an, und zwar immer so, dass nicht überschrieben wird (dann würden eventuell händisch gesetzte Berechtigungen erhalten bleiben), sondern per Löschen und neu Anlegen. Wenn man Euroscope im Programme-Ordner installiert hat, haken dazu noch SFP und UAC mit rein.

Wie @Paul Hollmann geschrieben hat, ist es daher keine gute Idee, Euroscope im Programme-Ordner zu installieren.

Gefährlich ist auch, wenn man Euroscope einmal als Admin gestartet hat. Dann haben alle neu angelegten Dateien Admin-Owner und Berechtigungen, und wenn man es danach wieder als normaler Nutzer startet, kommen genau diese Fehlermeldungen wie oben bei Dir.

In der ipaddr.txt werden die VATSIM-Serveradressen gespeichert. Da diese sich so häufig nicht ändern, mag es OK aussehen, wenn die Datei nicht geschrieben werden kann. Wenn dann aber doch mal eine Änderung kommt, ist die Sucherei nach dem Fehler noch schwieriger...
 
Okay, danke nochmal für die Info. Ich werde dann Euroscope in den nächsten Tagen nocheinmal neu direkt auf C:\ installieren. Ich hatte nur angenommen, dass dies von der Installation so richtig sei, da ich nirgendwo einen Hinweis auf solche Problematiken gefunden hatte. Aber dann weiß ich ja für den Re-Install bescheid.
 
Leider haben viele Entwickler sich nicht mit dem Installersystem und UAC etc. beschäftigt und gehen dann den Weg des geringsten Widerstands und meinen dann Installation außerhalb der protected Bereiche fordern zu müssen, als ihr Zeug ordentlich auffe Kette zu bringen. Genauso wie Euroscope leider Beispielconfigdateien im Installer als Teil des Programms der geschützt werden muß (bei jeden Start wirds drübergebügelt!) klassifiziert, statt korrekterweise als Configdateien...
 

Dominik Samuelis

842558
RG Frankfurt - NAV
Leider haben viele Entwickler sich nicht mit dem Installersystem und UAC etc. beschäftigt und gehen dann den Weg des geringsten Widerstands
Hehe, Euroscope gibt es schon länger als UAC und SFP. Das ist zwar keine Rechtfertigung, aber vielleicht trotzdem eine Begründung.

Wir können ja schon froh sein, dass Gergely sich überhaupt wieder mehr um ES kümmert, vielleicht kommt irgendwann ja auch ein vernünftiger Installer mit korrekter Nutzung von %appdata% für config. Vorher hat aber sicher native AfV-Einbindung Prio, und mit dem Workarounds funktionierts ja ganz gut.
 
Oben