Mikrofon (Sennheiser USB-Headset) funktioniert nicht im vPilot/MSFS

Sascha Ley

1425679
Hallo Zusammen,

mein neues Sennheiser Headset scheint Probleme mit dem vPilot (MSFS) zu haben. Obwohl das Mikro in anderen Anwendungen ordnungsgemäß funktioniert, bin ich auf VATSIM nicht zu hören. PTT ist korrekt eingestellt (RX/TX weiß, bei PTT wird TX blau hinterlegt, die Gegenseite hört wohl auch das Funkrauschen, jedoch meine Stimme nicht. In den vPilot-Einstellungen (und in der Windows-Systemsteuerung) ist das Mikro als (einziges) Eingabegerät eingestellt.
Im "Audio"-Tab der vPilot-Einstellungen ist das Mikro sichtbar und ausgewählt, jedoch sehe ich bei Verwendung keine Ausschläge in der Test-Anzeige (Der blau-grün-rote Balken), auch dann nicht, wenn ich die Mikro-Lautstärke auf Maximal setze. Das Mikro ist nicht hardware- oder windows-seitig "gemutet".

...Hat jemand vielleicht einen Lösungsansatz?

Vielen Dank & frohes neues Jahr!
 
Zuletzt bearbeitet:

Jan Fries

1437847
Hallo,
mir würde dafür spontan die ganz tolle Berechtigungsfunktion von Windows 10 einfallen, sofern das genutzt wird. Schau mal in den Einstellungen, ob vPilot da auf das Mikrofon zugreifen darf.
 

Kai Bock

955925
Es liegt in der Regel nicht am Mikrofon, wenn Du in anderen Anwendungen das Mikrofon nutzen kannst.

Vielleicht auch ganz simpel das falsche Device in vPilot ausgewählt.
 
Welche anderen Anwendungen funktionieren denn?

Windows 10 kommt leider nicht mehr wirklich mit "Soundkarten" zurecht, da der von Microsoft stammende Treiber für standardkonforme generische Audio-Geräte schon seit Jahren (min. seit 2017) komplett verbuggt ist. Meiner Erfahrung nach kann es sein dass es zufällig vorübergehend an einem anderem USB-Anschluss funktioniert oder aber auch gar nicht mehr an dem Rechner - da hilft dann nur ein anderes Headset (idealerweise eins das eigene Treiber mitbringt statt auf Standardtreiber zu setzen).

Ein paar Dinge die Du noch probieren könntest:
  • Reboot ohne das Mikro vom Rechner zu trennen
  • alle anderen Anwendungen schließen die aufs Mikro zugreifen könnten (z.B. Skype, Discord, TeamSpeak, Webbrowser inkl. integrierte Webbrowser)
  • in der Systemsteuerung unter "Kommunikation" bei "Beim Erkennen von Kommunikationsaktivitäten" auf "Nichts unternehmen" stellen - sollte eigentlich was ganz anderes bewirken, regelt aber scheinbar auch manchmal das Mikro runter
  • Bzgl. anderen Programmen und MSFS fällt mir noch ein: Vielleicht spielt da auch diese Windows 10 Gamebar-App mit Xbox Live rein. Ich hab leider keine Ahnung was man da unternehmen kann, vielleicht klaut sich das ja exklusive Rechte aufs Mikrofon.
  • Den Game Mode von Windows 10 könnte man auch versuchen auf Verdacht abzudrehen (CompatibilityManager pro Anwendung, "Disable fullscreen optimizations"), wobei ich nicht weiß ob das bei MSFS überhaupt funktioniert (1. kommt das von Microsoft und 2. läuft es sicher in irgendeiner "Xbox"-Umgebung?).
Mit Admin-Rechten wird vPilot ja sicherlich bereits ausgeführt oder hat sich hier mit MSFS was geändert? Falls nicht: Unbedingt immer als Admin ausführen.
 
Zuletzt bearbeitet:
Hallo Sascha,

ich habe auch ein Sennheiser USB Headset in Benutzung. Sonntag habe ich erst vPilot gestartet und dann den USB-Hub, daraus resultierten dann Probleme bei der Nutzung des Mikros. Ich habe dann eine andere Soundkarte in der vPilot Config gewählt, das USB Headset aus und wieder eingeseteckt und dann die Konfiguration wieder auf das USB-Headset zurück gestellt. Dann funktionierte es wieder einwandfrei.
Grundsätzlich habe ich aber keine Probleme mit dem Headset weder im Officebetrieb noch im Spielbetrieb mit vPilot und P3Dv4.

Viel Erfolg beim Reparieren
Martin
 

Sascha Ley

1425679
Vielen Dank soweit für Eure Mühe!
Ich bin leider auch damit noch nicht weitergekommen. Mit dem Mikro kann ich zumindest in Audacity -bei unveränderter Konfiguration- problemlos aufnehmen. Auch Discord ist kein Problem. Änderungen an der Konfiguration kann ich eigentlich ebenfalls ausschließen - außer, dass ich Teamspeak 2 & 3 jüngst vom Rechner geschmissen habe. Das sollte aber nichts ändern, oder?
In den Xbox-Apps fand ich auch keine "passenden" Optionen, die etwas verhindern könnten.
Ein Rechte-Problem ("Datenschutzeinstellungen") liegt offenbar auch nicht vor - zumindest sind xpilot & vpilot in der "Desktop-Apps den Zugriff erlauben-Liste" aufgeführt. Allerdings erscheint im Desktop-Tray kein Mikrofon-Symbol ("Eine Anwendung nutzt das Mikro"), was mich auch stutzig macht.
vpilot wurde zwischenzeitlich deinstalliert & neu installiert und läuft mit Admin-Rechten.

Ich bin ratlos. Vielleicht fällt jemandem noch etwas ein?
 
Hallo,

Eine Idee noch zu Deinem Problem: Welche Qualitätsrate ist beim Mikro eingestellt? Ich verwende Voicemeeter Banana für mein Audio-Setup, damit ich Audio beliebig zwischen Kopfhörer und Lautsprecher routen kann. Und da war vPilot etwas zickig in Bezug auf Sample Rate und Audio Device. WDM hat nicht funktioniert aber KS schon. Vielleicht gibt das ja eine Spur bei Dir. Und schaue mal, ob die Einstellung, ob das Mikro exklusiv verwendet wird, einen Unterschied macht.

LG
Reinhard
 

Dominik Samuelis

842558
RG Frankfurt - NAV
Ich hatte selber mal ein Sennheiser Headset (PC8 USB), das keinen Ton ausgegeben hat, wenn der Audiotreiber auf 44.1 kHz Samplingrate eingestellt war, bzw. eine Applikation den Ton auf 44.1 kHz heraushaben wollte (Euroscope z.B.). Nur auf 48 kHz hat es funktioniert, was mit dem damaligen Audiocodec von VATSIM nicht kompatibel war.

Mit Voicemeeter o.ä. konnte man das zwar "resamplen", aber ich habe es dann nicht weiter verwendet und nutze es jetzt nur am Firmenlaptop mit Skype for Business :)
 

Sascha Ley

1425679
Hmm. Danke sehr! Ich spiele später mal mit der Sample-Rate herum und schaue, ob das hilft. Das scheint letztlich tatsächlich ein vpilot-Problem zu sein. Da die andere Plattform (Die, die so ähnlich wie "ICAO" klingt) mit dem Mikro keine Probleme macht, werde ich erstmal dort meine Runden drehen. Hmpf.
 
Daniel hat es zwar schon erwähnt, aber doppelt hält manchmal besser: vPilot musst du mit rechter Maustaste "als Administrator ausführen" starten.
 
Oben